by

WordPress Will Update Its Minimum Allowed PHP Version As Of Version 5.2

For as long as anyone in the WordPress community can remember, the minimum allowed version of php on which WordPress will run has been well behind modern php versions, thanks to WordPress’s commitment to backwards compatibility. As of version 5.2, (due out in April) the minimum allowed version will be raised to php version 5.6, from it’s current allowed version of 5.2. Eight-five percent of all sites running WordPress 5.0 are running on php 5.6 or above, and high-profile plugins have been experimenting with user notifications encouraging an upgrade to a modern version of php, with quite a lot of success.

While php 5.6 reached end-of-life as of December 31, 2018, WordPress’s step to make it the minimum allowed version while continuing to encourage usage of php 7.2 and above is an important one. For one thing, it means that securing installations will be just a bit easier, and for another, the minimum allowed version change, coupled with encouragement to use a truly modern version, as well as allowing plugin authors to specify a supported php version, will make life a lot easier for those of us maintaining code.

Most hosts, especially the larger ones, have already either migrated to php 7.2 or above, or are strongly encouraging their users to do so. Note that if you’re running a virtual private server or similar, you will be required to manage the php upgrade yourself. If you happen to be a user or organization running on a virtual private server, and you are not technically proficient enough to manage the upgrade, you’ll want to make arrangements for someone to upgrade for you. I mention this last point because in the laast few weeks I’ve run into a lot of cases where users or organizations have been talked into hosting on a virtual private server or similar which they are unable to manage and which they have no one to manage for them. I’m not sure if this is an actual trend or whether or not I’m just personally/professionally encountering a lot of these. Anyway, think of the web, and upgrade your php installation if you haven’t already.


Respond

Leave a Reply

Discuss this

Comment

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.